CONTOH SOAL VLAN

Posted on Updated on

Setting Vlan

Vlan atau Virtual LAN berguna untuk memudahkan pengaturan dalam konfigurasi LAN dan berguna untuk membagi berdasarkan kebutuhan organisasi. Umumnya pembagian vlan dikategorikan berdasarkan lantai atau departemen di unit kerja organisasi dengan kelas IP yang berbeda namun mereka masih dapat berkomunikasi satu sama lain layaknya dalam satu LAN. Yang dibutuhkan adalah manageable switch dan router yang akan merouting class2 IP yang ada didalam vlan.

Gimana kalau kita langsung aja yah, jangan lupa siapkan rokok, teh manis, kacang ehhh blm bukaaa tau .

Scenarionya gini, kita akan membuat vlan berdasarkan lantai yang ada digedung tempat kita bekerja yah (secara kantor saya setupnya kurang lebih seperti ini, biar ga repot2 nulisnya ajah ). Yah ga semua lantai kaleee, secara lantai2 lain kan punya kantor lain kalee . Serius mode on: kantor kita memiliki 3 lantai, dan kita akan membagi masing2 lantai dengan class IP yang berbeda.

  • Lantai 1 – Vlan 10 (192.0.0.1/24 & Gateway 192.0.0.254)
  • Lantai 2 – Vlan 20 (10.0.0.1/8 & Gateway 10.0.0.254)
  • Lantai 3 – Vlan 30 (128.0.0.1/16 & Gateway 128.0.0.254)

Perangkat yang kita miliki satu router, dan 4 manageable switch. 3 switch akan ditempatkan dimasing2 lantai dan satu lagi langsung dibelakang router. Perangkat yang akan dikonfigurasi ialah router dan switch yang berada dibelakang router, jadi konfigurasinya di satu switchnya itu aja. Kurang lebih topologinya seperti ini

Biar memudahkan konfigurasi dan maintenance (nantinya), dimasing2 device kita beri identitas. Identitasnya seperti apa ya nanti disesuaikan saja sama kepentingan kalian, yang penting pemberian nama device itu konsisten. Yang saya gunakan seperti yang diatas, dan berikut penjelasannya

Konfigurasi Main Switch (yang berada dibelakang router)
Port Fastethernet 0/1 Vlan 10 (lantai 1)
Port Fastethernet 0/10 Vlan 20 (lantai 2)
Port Fastethernet 0/20 Vlan 30 (lantai 3)
Port Fastethernet 0/24 trunk dan encapsulation

Ok, kita langsung yah.

Switch>en
Switch#config t
Switch(config)#hostname main_switch ==> nama switch
main_switch(config)#line console 0 ==> setting password console
main_switch(config)#login
main_switch(config)#password password1==> password: password1
main_switch(config)#enable secret password1 ==> encrypting
main_switch(config)#vlan 10 ==> Vlan 10 untuk lantai 1 dst
main_switch(config-vlan)#name lantai1
main_switch(config-vlan)#exit
main_switch(config)#vlan 20
main_switch(config-vlan)#name lantai2
main_switch(config-vlan)#exit
main_switch(config)#vlan 30
main_switch(config-vlan)#name lantai3
main_switch(config-vlan)#exit
main_switch(config)#interface fastethernet 0/1 ==> Port 0/1 diassign untuk Vlan 10 (lantai1)
main_switch(config-if)#switchport access vlan 10
main_switch(config-if)#exit
main_switch(config)#interface fastethernet 0/10 ==> Port 0/10 diassign untuk Vlan 20 (Lantai2)
main_switch(config-if)#switchport access vlan 20
main_switch(config-if)#exit
main_switch(config)#interface fastethernet 0/20
main_switch(config-if)#switchport access vlan 30 ==> Port 0/20 diassign untuk Vlan 30 (lantai3)
main_switch(config-if)#exit
main_switch(config)#interface fastethernet 0/24
main_switch(config-if)#switchport mode trunk
main_switch(config-if)#switchport trunk encapsulation dot1q
main_switch(config-if)#ctrl^z
main_switch#copy running-config startup-config

Nah kalau sudah, untuk melihat konfigurasi vlannya ketik sh vlan.
Sekarang kita akan konfigurasi routernya

Router>en
Router#config t
Router(config)#hostname HQ-JKT ==> nama router
HQ-JKT(config)#line console 0
HQ-JKT(config)#login
HQ-JKT(config)#password password1
HQ-JKT(config)#enable secret password1
HQ-JKT(config)#line vty 0 4
HQ-JKT(config)#password password2
HQ-JKT(config)#interface fastethernet 0/0
HQ-JKT(config-if)#no shut ==> aktifkan port FA 0/0
HQ-JKT(config)#interface fastethernet 0/0.10 ==> assign Vlan lantai 1
HQ-JKT(config-subif)#encapsulation dot1q 10
HQ-JKT(config-subif)#ip address 192.0.0.1 255.255.255.0
HQ-JKT(config-subif)#exit
HQ-JKT(config)#interface fastethernet 0/0.20 ==> assign Vlan lantai 2
HQ-JKT(config-subif)#encapsulation dot1q 20
HQ-JKT(config-subif)#ip address 10.0.0.254 255.0.0.0
HQ-JKT(config-subif)#exit
HQ-JKT(config)#interface fastethernet 0/0.30 ==> assign Vlan lantai 3
HQ-JKT(config-subif)#encapsulation dot1q 30
HQ-JKT(config-subif)#ip address 128.0.0.254 255.255.0.0
HQ-JKT(config-subif)#ctrl^z
HQ-JKT#copy running-config startup-config ==> save configurasi

Untuk melihat konfigurasinya sms ke ketik sh run. IP yang diassign di masing2 child FastEthernet ialah hanya gateway dan subnetnya saja. Selesai deh, sekarang di pc lantai 3 coba kamu ping ke 192.0.0.1 kalau reply berarti no problemo kl RTO kamu check lagi configurasinya yah.

Kalau Vlan-nya mau dibuat berdasarkan department yang ada dikantor kamu, vlan name lantai tinggal kamu ganti dengan departement ajah. Easy right.

Semoga dapat dimengerti dan bermanfaat.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s